Bushel - e-Sign is experiencing an outage. – Incident details

All systems operational

e-Sign is experiencing an outage.

Resolved
Major outage
Started 12 days agoLasted about 2 hours

Affected

Platform

Major outage from 9:14 PM to 11:39 PM

Mobile Apps and Customer Portal

Major outage from 9:14 PM to 11:39 PM

Updates
  • Resolved
    Resolved

    Our vendor let us know this issue has been resolved.

  • Identified
    Identified

    Our vendor has identified the issue and a fix is being implemented.

  • Investigating
    Investigating

    We have been made aware that our vendor for e-Sign is experiencing an outage.

    This outage affects: Sending signature requests, finished document delivery, and document signing through Dropbox Sign.

    They are currently investigating.