Scheduled for January 31, 2026 at 12:30 AM – February 02, 2026 at 2:00 PM
Affects
Platform
Under maintenance from 12:30 AM to 2:00 PM
Offer Management
Under maintenance from 12:30 AM to 2:00 PM
Updates
Completed
February 02, 2026 at 2:00 PM
Completed
February 02, 2026 at 2:00 PM
Maintenance was completed successfully.
In progress
January 31, 2026 at 12:30 AM
In progress
January 31, 2026 at 12:30 AM
Maintenance is now in progress
Planned
January 31, 2026 at 12:30 AM
Planned
January 31, 2026 at 12:30 AM
Our vendor will be performing scheduled maintenance on the Production Gateway, which will require a temporary service interruption of the Bushel Trade platform. The downtime is expected to begin at approximately 6:30pm CT and is anticipated to last up to 2 hours. During this time, access to trading services will be unavailable.
If you have any questions, please contact support@bushelpowered.com.