Scheduled for April 17, 2026 at 11:30 PM – April 18, 2026 at 1:30 AM
Affects
Platform
Under maintenance from 11:30 PM to 1:30 AM
Offer Management
Under maintenance from 11:30 PM to 1:30 AM
Updates
Completed
April 18, 2026 at 1:30 AM
Completed
April 18, 2026 at 1:30 AM
Maintenance has completed successfully
In progress
April 17, 2026 at 11:30 PM
In progress
April 17, 2026 at 11:30 PM
Maintenance is now in progress
Planned
April 17, 2026 at 11:30 PM
Planned
April 17, 2026 at 11:30 PM
Our vendor for the Bushel Trade platform will be performing maintenance on the Production environment on Friday, April 17, 2026, beginning at approximately 18:30 CT. This work requires a temporary outage of Bushel Trade.
The maintenance is expected to take approximately 1 to 1.5 hours, though timing may vary.