Bushel - eSign Site Temporarily Unavailable – Incident details

All systems operational

eSign Site Temporarily Unavailable

Resolved
Major outage
Started 9 days agoLasted 14 minutes

Affected

Platform

Major outage from 9:19 PM to 9:34 PM

Mobile Apps and Customer Portal

Major outage from 9:19 PM to 9:34 PM

Updates
  • Resolved
    Resolved

    The issue is resolved and our eSign Site is now available.

    We apologize for any inconvenience.

  • Identified
    Identified

    There is currently an issue that is causing the eSign site to be temporarily unavailable. Our engineers are actively working on resolving the issue.